Entity3d Class

This class is the base class for all 3D geometric entities. For more information, see Overview of OdGe classes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        More

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public abstract class Entity3d : DisposableWrapper, 
        ICloneable

The Entity3d type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Public method Clone Clones this entity and returns a handle to the cloned entity.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method IsEqualTo(Entity3d) Checks whether this entity is equal to the specified entity.
Public method IsEqualTo(Entity3d, Tolerance) Checks whether this entity is equal to the specified entity within a geometric tolerance.
Public method IsOn(Point3d) Checks whether the specified point is on this entity.
Public method IsOn(Point3d, Tolerance) Checks whether the specified point is on this entity according to a geometric tolerance.
Public method Mirror Mirrors this entity about the specified plane.
Public method RotateBy Rotates this entity by the specified angle about the axis defined by the point and the vector.
Public method ScaleBy Scales this entity by the scale factor about the specified point.
Public method TransformBy Applies the specified 2D transformation matrix to this entity.
Public method TranslateBy Translates this entity by applying a 3D translation vector.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryBoundBlock3d
        Teigha.GeometryCurve3d
        Teigha.GeometryCurveCurveIntersector3d
        Teigha.GeometryPointEntity3d
        Teigha.GeometrySurface
        Teigha.GeometrySurfaceSurfaceIntersector

©  Bricsys NV. All rights reserved.