AbstractClipBoundary Class

This .NET class wraps the OdGiAbstractClipBoundary class which is the base class for passing additional clip boundary information from OdGiDrawable objects to the underlying OdGi system. For more information, see Working with the Clipping Engine.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GraphicsInterfaceAbstractClipBoundary

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class AbstractClipBoundary : DisposableWrapper

The AbstractClipBoundary type exposes the following members.

Constructors
  Name Description
Public method AbstractClipBoundary Default constructor for the AbstractClipBoundary class. Constructs an empty clip boundary.
Top
Properties
  Name Description
Public property BoundaryType Property that represents the boundary type for a clip boundary.
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.