Quad
|
The QuadReactor type exposes the following members.
Name | Description | |
---|---|---|
![]() |
QuadReactor | Initializes a new instance of the QuadReactor class |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
appendQuadItems(QuadItems) | This function is called when the no-selection Quad is to be shown. Add selection-independent items in this function. |
![]() |
appendQuadItems(QuadSelection, QuadItems) | Implement appendQuadItems to append QuadItems to the Quad. This function will be called when the Quad is about to be shown. Only those QuadItems that have been registered will be successfully appended. Several reactors may be registered, but only those which are active (as per settings) will append their items to the Quad. * This function is called when a Quad is to be shown for a selection. AcEdQuadSelection can be queried further for hovered and pickfirst selection data, to make intelligent decisions of relevant QuadItems to be added to the Quad. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
displayName | The display name will be shown to users in the UI for identifying/enabling/disabling/ prioritising your reactor. |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetImpObj | |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
GUID | The GUID has to be a globally unique identifier (use VS201x->Tools->CreateGUID, "guidgen.exe") and will be used to internally identify the reactor across sessions, releases and different third party applications, so it should always be the same for this reactor. Therefore, once a reactor is published by a developer, its GUID should NEVER be changed. Note : any string format from "CreateGUID" / "guidgen.exe" is accepted, suggested format is like "C2160591-FC06-4A74-A9B8-2E28635279BA" (not brackets) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject) |
![]() |
registerQuadItems | This function is called whenever BricsCAD needs to know ALL the commands supported by your reactor during, but not limited to loading of your module, adding your reactor to the AcEdQuadReactorManager, displaying the CUI dialog. Your implementation of this interface is expected to call AcEdQuadItemRegistry::append() for each QuadItem your reactor supports / requires. If a QuadItem has not been registered, AcEdQuadItems::append will not append that QuadItem to the Quad when its shown. |
![]() ![]() |
registerQuadReactor | Registers a Quad reactor. Reactor is added to the internal list, but caller owns the memory. Function returns false if another reactor has same GUID (the reactor will not get added in that case). |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() ![]() |
unregisterQuadReactor | Unregisters a Quad reactor. Reactor is removed from the internal list, caller still owns the memory. Function returns false if reactor was not present in the list. |
© Bricsys NV. All rights reserved. |