param:constraint-get-isenabled


(param:constraint-get-isenabled  constraint)

Returns whether the specified constraint (integer) is enabled or not.

Arguments

constraint (integer) the constraint to query

Return

T or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(mech:constraint-get-isenabled constraint)  T

Remarks


Note




©  Bricsys NV. All rights reserved.