param:get-constraints


(param:get-constraints  idBlock  [ createIfNotExist ])

Returns the list of 3DConstraints for the specified idBlock (ename) BlockTableRecord;
if no constraints group is assigned to idBlock and createIfNotExist is non-NIL, a new constraint group is created.

Arguments

idBlock (ename) the BlockTableRecord to query

createIfNotExist (T/NIL) if specified as non-NIL, a new ConstraintGroup is created for the idBlock BlockTableRecord if missing yet

Return

list of integers or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a3c8b900>
(setq grp ((param:get-constraintsgroup blkId))  2752346592
((param:get-constraints grp)  (2752356192)

Remarks


Note




©  Bricsys NV. All rights reserved.