param:get-constraintsgroup


(param:get-constraintsgroup  idBlock  [createIfNotExisting])

Returns the ConstraintsGroup identifier for the specified idBlock BlockTableRecord; if not existing and createIfNotExisting is non-NIL, a new ConstraintsGroup is created and attached to the BlockTableRecord.

Arguments

idBlock  (ename) specifies the BlockTableRecord ("Block") to retrieve the assigned ConstraintGroup from

createIfNotExisting (T/NIL) if provided as T, a new ConstraintGroup is assigned to the BlockTableRecord, if not existign yet

Return

the "integer identifier" of the existing (or created) ConstraintGroup if the specified BlockTableRecord;
NIL is returned if no ConstraintGroup is attached to the specified BlockTableRecord

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))      ;; get the ModelSpace BlockTableRecord
(setq res ((param:get-constraintsgroup blkId))                 ;; returns existing ConstraintsGroup, or NIL
(setq res ((param:get-constraintsgroup blkId T))              ;; returns existing ConstraintsGroup, or create a new ConstraintsGroup in "Model_Space"

Remarks


Note




©  Bricsys NV. All rights reserved.