param:parameters-get-unitstype


(param:parameters-get-unitstype  parameter)

Returns the unit mode of the specified parameter (integer).

Arguments

parameter (integer) the parameter identifier to query

Return

integer (None=0, Length=1, Area=2, Volume=3) or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: 4aaa68b0>
(setq param (mech:parameters-get-byname blkId "Length"))  971708080
(mech:parameters-get-unitstype param)  0

Remarks

for the returned value, see 3DC Parameters Units Type

Note




©  Bricsys NV. All rights reserved.