Extra LISP functions

Following functions - which are not part of standard AutoLISP® - also are available in BricsCAD.

 

Additional functions not available in AutoLISP® :

(get_diskserialid)

Returns a 9-digit unique id string, based on the first hard disk serial number.

If the hard disk serial number can not be obtained in very rare cases, the 9-digit unique id string is based on the serial number of the first partition.

This id string provides a licensing/hardlocking feature for LISP applications.

(acos x)

Returns the arc cosine of x.

(cosh x)

Returns the hyperbolic cosine of x.

(asin x)

Returns the arc sine of x.

(sinh x)

Returns the hyperbolic sine of x.

(atanh x)

Returns the hyperbolic arc tangent of x.

(ceiling x)

Returns the smallest integer that is not smaller than x.

(find item list)

Returns item if item is found in list, otherwise it returns nil.

(floor x)

Returns the greatest integer less than or equal to x.

(getpid)

Returns the process ID of the current process.

(log10 x)

Returns the base-10 logarithm of x.

(position item list)

Returns the index ot item in list or nil (first index is 0).

(remove item list)

Returns the input list, with item removed from the list.   

(round x)

Returns the integer nearest to x.

(search list1 list2)

Searches for list1 in list2 and returns the index where found or nil (first index is 0).

(sleep millisecs)

Delays execution for (approx.) given milliseconds

(string-split string-of-delimiters string)

Returns a list of strings divided by any character in string-of-delimiters.

Example: (string-split " ,;" "aaa bbb;ccc,ddd") => ("aaa" "bbb" "ccc" "ddd")

(tan x)

Returns the tangent of x - x must be in radians.

(tanh x)

Returns the hyperbolc tangent of x.

(until test-expression [expression ... ])

Repeats the expression(s) until test-expression evaluates as T (true).

(vla-collection->list <collection-object>)

Returns a collection as a normal LISP list.

 

Tell me about...

Copying Code Examples from the BricsCAD Programmer’s Reference

Programming Overview of LISP (LISt Processing) Language


© Menhirs NV. All rights reserved.