Methods supporting Fast-COM

Parent Previous Next

Object Methods providing "Fast-COM"support


The Methods listed below are already implemented in Fast-COM mode (and are therefore available on Linux / Mac platforms as well);
all Methods not listed are managed by normal Windows COM (and are therefore not yet available on Linux / Mac platforms);
this is ongoing work, so more Methods will become available and listed here.

Method functions can be called in usual way - as dedicated functions (vla-<method> ...) or using generic (vlax-invoke-method '<method> ...), the "Fast-COM" mode covers both.



Activate
Add3dFace
Add3dMesh
Add3dPoly
AddArc
AddAttribute
AddBox
AddCircle
AddCone
AddCustomObject
AddCylinder
AddDim3PointAngular
AddDimAligned
AddDimAngular
AddDimArc
AddDimDiametric
AddDimRadial
AddDimRadialLarge
AddDimRotated
AddDimOrdinate

AddEllipse
AddEllipticalCylinder
AddEllipticalCone
AddExtrudedSolid
AddExtrudedSolidAlongPath
AddHatch
AddLeader
AddLightWeightPolyline
AddLine
AddMInsertBlock
AddMline
AddMText
AddPoint
AddPolyfaceMesh
AddPolyline
AddRaster
AddRay
AddRegion
AddRevolvedSolid

AddSection
AddShape
AddSolid
AddSphere
AddSpline
AddTable
AddText
AddTolerance
AddTorus
AddTrace
AddWedge
AddXLine

Close
Copy

Delete
DxfIn
DxfOut

EndUndoMark



GetInterfaceObject

HandleToObject
Highlight

InsertBlock
IntersectWith
Item


ListArx
LoadArx



Mirror
Mirror3d
Move


ObjectIdToObject
Open


Quit



Regen
Rotate
Rotate3d

Save
SaveAs
ScaleEntity
SendCommand
StartUndoMark

UnloadArx
Update

ZoomAll
ZoomCenter
ZoomExtents
ZoomPickWindow
ZoomPrevious
ZoomScaled
ZoomWindow













©  Menhirs NV. All rights reserved.