dictobjname

Parent Previous Next

dictobjname


(dictobjname  dictname  itemname)

verifies whether the dictionary 'dictname' contains an entry 'itemname' and returns the entity name or NIL

Arguments

'dictname'  entity name of the dictionaty to search in
'itemname'  the entry name to search for

Return

the ename of the dictionary item 'itemname', if present;
NIL if the dictionary 'dictname' does not contain 'itemname'

Example

(vle-dictobjname (namedobjdict) "ACAD_GROUP")
returns the ename of the group dictionary, NIL otherwise

Alias


Remarks

this is a fast replacement for (cdr (assoc -1 (dictsearch dictname itemname)));
this function is deprecated; please use (vle-dictobjname) instead




©  Menhirs NV. All rights reserved.