vle-list-diff

Parent Previous Next

vle-list-diff


(vle-list-diff  lst1  lst2)

returns the "list difference" of 2 lists, containing all items, which are member of either 'lst1' or 'lst2', but not member of both lists

Arguments

'lst1'  list to be compared against 'lst2'
'lst2'  list to be compared against 'lst1'

Return

a list containing all items which are unique for their owner lists; in other words, which are not member of both lists

Example

(vle-list-diff '(1 2 3 3 4) '(3 4 5 6))  => '(1 2 5 6)
(vle-list-diff '(1 2 3 3 4) '(5 6 7 8))  => '(1 2 3 3 4 5 6 7 8)
(vle-list-diff '(1 2 3 3 4) nil)  => '(1 2 3 3 4)

Alias


Remarks





©  Menhirs NV. All rights reserved.