vle-remove-nth

Parent Previous Next

vle-remove-nth


(vle-remove-nth  idx  lst)

removes the object at index 'idx' from list 'lst'

Arguments

'idx'  index of the item to be removed;
        if negative, or 'lst' contains less items, nothing is removed
'lst'  normal Lisp list

Return

list 'lst' without item at position 'idx';
if 'idx' is not in the list, the unchanged list 'lst' is returned

Example

(vle-remove-nth 3 '(1 2 123 4 5 123 6 7 8))
returns '(1 2 123 5 123 6 7 8)

Alias

vle-remove-idx

Remarks

index is 0-based




©  Menhirs NV. All rights reserved.