vle-string-split

Parent Previous Next

vle-string-split


(vle-string-split  keys  string)

splits the given string 'string' into string-tokens, based on delimiter characters as specified by 'keys'

Arguments

'keys'  string containing all delimiter characters to be used
'string'  the string to be splitted into tokens

Return

list of string tokens;
if none of the 'keys' characters is present in string, the list contains only the original string (1 token)

Example

(vle-string-split ",;" "Sample, using different keys; voila")
returns   '("Sample" " using different keys" " voila")

Alias

vl-string-split
string-split

Remarks

if no <delimiter> character is contained, the returned list will contain v the original string




©  Menhirs NV. All rights reserved.