vle-rgb2aci


(vle-rgb2aci  rgb)
(vle-rgb2aci  red  green  blue)

Returns the closest ACI color index for specified RGB color value.

Arguments

'rgb'  an integer specifying the RGB value
'red'  an integer specifying the red value part (0...255)
'green'  an integer specifying the green value part (0...255)
'blue'  an integer specifying the blue value part (0...255)

Return

always returns an integer value

Example

(vle-rgb2aci 0 0 255)  returns  5
(vle-rgb2aci 0 76 57)  returns 128
(vle-rgb2aci 16711680)  returns 5

Alias


Remarks

the vle-extension.lsp emulation for non-BricsCAD systems only supports the (vle-rgb2aci  red  green  blue) syntax !




©  Bricsys NV. All rights reserved.