IAcSmCustomPropertyValue


The interface to custom property value in an IAcSmDatabase object.

available methods :

(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq sheetset (vlax-invoke-method smdb 'GetSheetSet))
(setq custProps (vlax-invoke-method sheetset "GetCustomPropertyBag"))
(setq iter (vlax-invoke-method custProps 'GetPropertyEnumerator))
(vlax-invoke-method iter 'Next 'propname 'propobj)

GetValue

returns the associated VARIANT value

(setq res (vlax-invoke-method propobj 'GetValue))

HRESULT GetValue ([out, retval] VARIANT* value)

SetValue

assigns the associated VARIANT value

(vlax-invoke-method propobj 'SetValue "New Text")

HRESULT SetValue ([in] VARIANT value)

GetFlags

returns the property flags associated with this value

(setq flags (vlax-invoke-method propobj 'GetFlags))

HRESULT GetFlags ([out, retval] PropertyFlags* flags)

SetFlags

assigns the property flags associated with this value

(vlax-invoke-method propobj 'SetFlags flags)

HRESULT SetFlags ([in] PropertyFlags flags)



©  Bricsys NV. All rights reserved.