IAcSmFileReference
The Sheet ObjectId interface (reference to
file object).
available methods :
(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument
cad))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
(setq sheetset (vlax-invoke-method smdb
'GetSheetSet))
(setq fileref (vlax-invoke-method sheetset
"GetNewSheetLocation"))
SetFileName |
assigns the filename that
this object will reference |
GetFileName |
returns the filename of this
file reference |
ResolveFileName |
resolves the referenced file
as fully qualified filename |
© Bricsys NV. All rights reserved. |