IAcSmNamedAcDbObjectReference
The interface for a "named" AcDbObject
object.
available methods :
(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
(setq sheetset (vlax-invoke-method smdb
'GetSheetSet))
(setq dwtLayout (vlax-invoke-method sheetset
'GetDefDwtLayout))
SetName |
assigns a new name for the
referenced object |
GetName |
returns the name of the
referenced object |
SetOwnerAcDbHandle |
assigns the AcDbHandle (as a
string) of the owning AcDbObject; needed since the name by itself
does not provide enough information about the nature of the
referenced AcDbObject |
GetOwnerAcDbHandle |
returns the AcDbHandle (as a
string) of the parent AcDbObject of the referenced
object |
© Bricsys NV. All rights reserved. |