IAcSmObjectId


The Sheet ObjectId interface (unique object identification).

available methods :

(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument cad))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq smObjectId (vlax-invoke-method smdb 'GetObjectId))

GetHandle

returns the persistent (unique) string handle

(setq res (vlax-invoke-method smObjectId 'GetHandle))

HRESULT GetHandle ([out, retval] BSTR* handle)

GetDatabase

returns the owning IAcSmDatabase

(setq res (vlax-invoke-method smObjectId 'GetDatabase))

HRESULT GetDatabase ([out, retval] IAcSmDatabase** ppDb)

GetPersistObject

returns the instance of the persistent component that this IAcSmObjectId identifies

(setq res (vlax-invoke-method smObjectId 'GetPersistObject))

HRESULT GetPersistObject ([out, retval] IAcSmPersist** ppObj)

GetOwner

returns the owning component

(setq res (vlax-invoke-method smObjectId 'GetOwner))

HRESULT GetOwner ([out, retval] IAcSmPersist** ppObj)

IsEqual

compares this IAcSmObjectId with another one, returns true if both IDs reference the same component

(setq res (vlax-invoke-method smObjectId 'IsEqual smObjectId))

HRESULT IsEqual ([in] IAcSmObjectId* pId, [out, retval] VARIANT_BOOL* pResult)

IsValid

returns whether this IAcSmObjectId is valid

(setq res (vlax-invoke-method smObjectId 'IsValid))

HRESULT IsValid ([out, retval] VARIANT_BOOL* pResult)



©  Bricsys NV. All rights reserved.