IAcSmPersist


The interface to persistent objects in an IAcSmDatabase object.

available methods :

(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq sheetset (vlax-invoke-method smdb 'GetSheetSet))
(setq custProps (vlax-invoke-method sheetset "GetCustomPropertyBag"))
(setq iter (vlax-invoke-method custProps 'GetPropertyEnumerator))
(vlax-invoke-method iter 'Next 'propname 'propobj)



GetClassID

returns the CLSID of the COM CoClass that implements this object

(not callable from LISP)

HRESULT GetClassID ([out, retval] GUID* pGuid)

GetIsDirty

returns whether this object is in modified state

(setq res (vlax-invoke-method propobj 'GetIsDirty))

HRESULT GetIsDirty ([out, retval] VARIANT_BOOL* pVal)

Load

reserved for future use : loads the object using the provided filer

(vlax-invoke-method propobj 'Load ssmFiler)

HRESULT Load ([in] IAcSmFiler* pFiler)

Save

reserved for future use : saves the object to the provided filer

(vlax-invoke-method propobj Save ssmFiler)

HRESULT Save ([in] IAcSmFiler* pFiler)

GetTypeName

returns the object's COM CoClass descriptive name

(setq res (vlax-invoke-method propobj 'GetTypeName))

HRESULT GetTypeName ([out, retval] BSTR* pTypeName)

InitNew

initializes this instance

(vlax-invoke-method propobj 'InitNew custProps)

HRESULT InitNew ([in] IAcSmPersist* pOwner)

GetOwner

returns the owning IAcSmPersist parent object of this object

(setq ownerobj (vlax-invoke-method propobj 'GetOwner))

HRESULT GetOwner ([out, retval] IAcSmPersist** ppOwner)

SetOwner

assigns the owner IAcSmPersist object for this object

(vlax-invoke-method propobj 'SetOwner newOwner)

HRESULT SetOwner ([in] IAcSmPersist* pOwner)

GetDatabase

returns the IAcSmDatabase that this object lives in

(setq acsmdb (vlax-invoke-method propobj 'GetDatabase))

HRESULT GetDatabase ([out, retval] IAcSmDatabase** ppDb)

GetObjectId

returns the IAcSmObjectId of this object

(setq objid (vlax-invoke-method propobj 'GetObjectId))

HRESULT GetObjectId ([out, retval] IAcSmObjectId** ppId)

Clear

reset this object and perform clean-up; leaves it in an uninitialized state

(vlax-invoke-method propobj 'Clear)

HRESULT Clear ()

GetDirectlyOwnedObjects

returns an array of the directly owned objects

(not callable from LISP)

HRESULT GetDirectlyOwnedObjects ([out] SAFEARRAY(IUnknown*)* objects)

GetDirectlyOwnedObjectsArray

returns an array of the directly owned objects

(setq res (vlax-invoke-method propobj 'GetDirectlyOwnedObjectsArray)

HRESULT GetDirectlyOwnedObjectsArray ([out, retval] SAFEARRAY(IUnknown*)* objects)



©  Bricsys NV. All rights reserved.