IAcSmPublishOptions


The interface to Publish options.

available methods :

(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq sheetset (vlax-invoke-method smdb 'GetSheetSet))
(setq pbOptions (vlax-invoke-method sheetset 'GetPublishOptions))

GetDefaultOutputdir

returns an IAcSmFileReference for the default output directory

(setq fileref (vlax-invoke-method pbOptions 'GetDefaultOutputdir))

HRESULT GetDefaultOutputdir ([out, retval] IAcSmFileReference** ppValue)

SetDefaultOutputdir

assigns the default output directory

(vlax-invoke-method pbOptions 'SetDefaultOutputdir fileref)

HRESULT SetDefaultOutputdir ([in] IAcSmFileReference* pValue)

GetDwfType

returns the DWF file type property

(setq res (vlax-invoke-method pbOptions 'GetDwfType))

HRESULT GetDwfType ([out, retval] VARIANT_BOOL* pValue)

SetDwfType

assigns the DWF file type property

(vlax-invoke-method pbOptions 'SetDwfType :vlax-false)

HRESULT SetDwfType ([in] VARIANT_BOOL value)

GetPromptForName

returns the boolean flag indicating whether the application should prompt for name

(setq res (vlax-invoke-method pbOptions 'GetPromptForName))

HRESULT GetPromptForName ([out, retval] VARIANT_BOOL* pValue)

SetPromptForName

assigns the boolean flag indicating whether the application should prompt for name

(vlax-invoke-method pbOptions 'SetPromptForName :vlax-true)

HRESULT SetPromptForName ([in] VARIANT_BOOL value)

GetUsePassword

returns the boolean flag indicating whether a password should be used

(setq res (vlax-invoke-method pbOptions 'GetUsePassword))

HRESULT GetUsePassword ([out, retval] VARIANT_BOOL* pValue)

SetUsePassword

assigns the boolean flag indicating whether a password should be used

(vlax-invoke-method pbOptions 'SetUsePassword :vlax-false)

HRESULT SetUsePassword ([in] VARIANT_BOOL value)

GetPromptForPassword

returns the boolean flag indicating whether a password should be prompted for

(setq res (vlax-invoke-method pbOptions 'GetPromptForPassword))

HRESULT GetPromptForPassword ([out, retval] VARIANT_BOOL* pValue)

SetPromptForPassword

assigns the boolean flag indicating whether a password should be prompted for

(vlax-invoke-method pbOptions 'SetPromptForPassword :vlax-false)

HRESULT SetPromptForPassword ([in] VARIANT_BOOL value)

GetLayerInfo

returns the boolean flag indicating whether layer info should be used

(setq res (vlax-invoke-method pbOptions 'GetLayerInfo))

HRESULT GetLayerInfo ([out, retval] VARIANT_BOOL* pValue)

SetLayerInfo

assigns the boolean flag indicating whether layer info should be used

(vlax-invoke-method pbOptions 'SetLayerInfo :vlax-true)

HRESULT SetLayerInfo ([in] VARIANT_BOOL value)

GetUnrecognizedData

returns the publish options 'Unregcognized Data'; see publish API for documentation and use

(setq unknownData (vlax-invoke-method pbOptions 'GetUnrecognizedData))

HRESULT GetUnrecognizedData ([out, retval] IAcSmCustomPropertyBag** bag)

SetUnrecognizedData

assigns the publish options 'Unregcognized Data'; see publish API for documentation and use

(vlax-invoke-method pbOptions 'SetUnrecognizedData unknownData)

HRESULT SetUnrecognizedData ([in] IAcSmCustomPropertyBag* bag)

GetUnrecognizedSections

returns the publish options 'Unregcognized Section Array'; see the AcPlDSDData publish API

(setq unknownSections (vlax-invoke-method pbOptions 'GetUnrecognizedSections))

HRESULT GetUnrecognizedSections ([out, retval] IAcSmCustomPropertyBag** sectionArray)

SetUnrecognizedSections

assigns the publish options 'Unregcognized Section Array'; see the AcPlDSDData publish API

(vlax-invoke-method pbOptions 'SetUnrecognizedSections unknownSections)

HRESULT SetUnrecognizedSections ([in] IAcSmCustomPropertyBag* sectionArray)



©  Bricsys NV. All rights reserved.