IAcSmSheet
The Sheet component interface.
available methods :
(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument
cad))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
(setq layouts (vla-get-layouts
doc))
(setq layout (vla-item layouts
"A1"))
(setq smdb (vlax-invoke-method ssmgr
'GetSheetFromLayout layout 'objSheet))
GetNumber |
returns the number property
of this sheet |
SetNumber |
assigns the number property
for this sheet |
GetTitle |
returns the title property of
this sheet |
SetTitle |
assigns the title property
for this sheet |
GetLayout |
returns the
IAcSmAcDbLayoutReference which references the AcDbLayout associated
with this sheet |
SetLayout |
assigns the
IAcSmAcDbLayoutReference which references the AcDbLayout associated
with this sheet |
GetDoNotPlot |
returns whether this sheet
should be skipped during plot and publish operations |
SetDoNotPlot |
defines whether this sheet
should be skipped during plot and publish operations |
GetSheetViews |
returns the sheet views
collection of this sheet |
© Bricsys NV. All rights reserved. |