Add method

Creates a member object and adds it to the appropriate collection. The syntax varies depending on which object is being created.

 

Syntax

For the following collection objects: DimensionStyles, Layers, Linetypes, SelectionSets, TextStyles, Views, and Viewports, use the following syntax:

objectVariable = object.Add(Name)

For the Blocks collection object:

objectVariable = object.Add(InsertionPoint,Name)

For the UCSs collection object:

objectVariable = object.Add(Origin, XAxisPoint, YAxisPoint, Name)

Where:

Name is a string representing the name of the object to be created;

InsertionPoint is a Variant representing the coordinates where the Blocks Collection object will be added;

Origin is a Variant representing the coordinates where the UCS will be added;

Xaxis and Yaxis are Vector objects representing the respective axes of the UCS.

 

Examples...

InsertBlock method example

 


© Bricsys NV. All rights reserved.