AddAttributeDef method

Adds an Attribute Definition at the given insertion point and other attribute information.

 

Syntax

objectVariable = object.AddAttributeDef(Height, Mode, Prompt, InsertionPoint, Tag, Value)

Where:

     object is one of the ModelSpace or PaperSpace collection objects or a Block object;

     Height is a double-precision variable representing the height (in drawing units) of the attribute text.

     Mode is one of the following (acAttributeMode) attribute modes:

     acAttributeModeNormal

     acAttributeModeInvisible

     acAttributeModeConstant

     acAttributeModeVerify

     acAttributeModePreset

     Prompt is a string variable representing the text to be displayed to the user;

     InsertionPoint is a Variant representing the location of the attribute;

     Tag is a string variable identifying each occurrence of the attribute;

     Value is a string variable representing the default value of the attribute.

 


© Bricsys NV. All rights reserved.