AddHatch method

Creates a new hatch object and adds it to the drawing.

 

Syntax

objectVariable = object.AddHatch(PatternType , PatternName, Associativity , [HatchObjectType])

Where:

     objectVariable is a AcadHatch object;

     object is one of the ModelSpace or PaperSpace collection objects or a Block object;

     PatternType is a Long integer representing one of the following HatchType constants:

acHatchPatternTypePreDefined = 1

acHatchPatternTypeUserDefined = 0

acHatchPatternTypeCustomDefined = 2

     PatternName is a String representing the name of the hatch pattern to be used.

     Associativity Boolean whether or not the hatch is associative;

Examples...

AddHatch method example

 

 


© Bricsys NV. All rights reserved.