ArrayPolar method

Creates a polar array.

 

Syntax

objectVariable = object.ArrayRectangular(NumberOfObjects, IncludedAngle, CenterPoint, [PointOnAxis], [RotateObjects])

Where:

     object is one of the ModelSpace or PaperSpace collection objects or a Block object;

     NumberOfObjects is the number of objects in the array;

     IncludedAngle is the angle to fill in radians, with a positive value specifying counterclockwise rotation;

     CenterPoint is a Variant (three-element array of doubles) specifying the center point of the polar array;

     PointOnAxis  is an optional Variant (three-element array of doubles) indicating the point on the axis of rotation.

     RotateObjects is an optional Boolean variable indicating whether to rotate objects or not. The default is False (no rotation).

 

Examples...

ArrayPolar method example

 


© Bricsys NV. All rights reserved.