GetXData method

Returns the extended entity data (Xdata) associated with an object. VBA sees XData as a pair of arrays. The first array tells you what type of data (e.g., string or 3D point) is in the corresponding location in the second array (e.g., "Hi there" or 3,0,0). To get an entity's XData, you pass two empty arrays to GetXData. GetXData populates these arrays with the entity's XData. You can then iterate through the arrays and read the data. VBA uses the same datatype codes (1000 for a string, 1003 for a layer name, and so on) as Lisp.

 

Syntax

Sub GetXData(AppName, TypeArray, DataArray)

Where:

     AppName is a string representing the name of the application.

 

Examples...

GetXData method example

 


© Bricsys NV. All rights reserved.