InsertBlock method

Adds a new Block Insert object.

 

Syntax

objectVariable = object.InsertBlock([InsertionPoint], BlockName, [XScale], [YScale], [ZScale], [Rotation])

Where:

     InsertionPoint is a Variant representing the point at which the block will be inserted;

     object is one of the ModelSpace or PaperSpace collection objects or a Block object;

     BlockName is a string representing the name of the block;

     XScale, YScale, and ZScale are double-precision variables (or values) representing the scaling factors for the drawing along each coordinate plane;

     Rotation is a double-precision variable (or value) representing the rotation angle (in radians) for the external reference.

 

Examples...

InsertBlock method example


© Bricsys NV. All rights reserved.