Rotate3D method

Rotates the selection set and all its members about an axis formed by two points. The direction of the axis is from point1 to point2.

 

Syntax

object.Rotate3D(Point1, Point2, RotationAngle)

Where:

     object is a BricsCAD entity;

     Point1 is a Variant (three-element array of doubles) representing the first point of the axis about which objects will be rotated;

     Point2 is a Variant (three-element array of doubles) representing the second point of the axis about which objects will be rotated;

     RotationAngle is a double-precision variable (or value) representing the angle in radians.

 

Examples...

Rotate3D method example

 


© Bricsys NV. All rights reserved.