Select method

Selects objects within the rectangle specified by two points, and adds them to the SelectionSet.

 

Syntax

object.Select(Type, [Point1], [Point2], [FilterType], [FilterData])

Where:

     object is a SelectionSet object;

     Type is one of the following SelectionSetType constants corresponding to the various selection modes:

     acSelectionSetAll = 11

     acSelectionSetCrossingCircle = 3

     acSelectionSetCrossingPolygon = 0

     acSelectionSetCrossingWindow = 6

     acSelectionSetFence = 12

     acSelectionSetInsideCircle = 5

     acSelectionSetInsidePolygon = 2

     acSelectionSetInsideWindow = 8

     acSelectionSetLast = 10

     acSelectionSetOutsideCircle = 4

     acSelectionSetOutsidePolygon = 1

     acSelectionSetOutsideWindow = 7

     acSelectionSetPrevious = 9

     Point1 and Point2 are Variant (three-element array of doubles) defining a rectangle for those applicable selection modes;

     FilterType is an optional parameter for specifying how to filter data selection;

     FilterData is an optional parameter for specifying filter data.

 


© Bricsys NV. All rights reserved.