SelectByPolygon method

Selects objects within a polygon specified by the points, and adds them to the SelectionSet.

 

Syntax

object.SelectByPolygon(Type, PolygonPoints, [FilterType], [FilterData])

Where:

     object is a SelectionSet object;

     Type is one of the following SelectionSetType constants corresponding to the various selection modes:

     vicSelectionSetAll = 11

     vicSelectionSetCrossingCircle = 3

     vicSelectionSetCrossingPolygon = 0

     vicSelectionSetCrossingWindow = 6

     vicSelectionSetFence = 12

     vicSelectionSetInsideCircle = 5

     vicSelectionSetInsidePolygon = 2

     vicSelectionSetInsideWindow = 8

     vicSelectionSetLast = 10

     vicSelectionSetOutsideCircle = 4

     vicSelectionSetOutsidePolygon = 1

     vicSelectionSetOutsideWindow = 7

     vicSelectionSetPrevious = 9

     PolygonPoints is a collection of BricsCAD Points defining the polygon;

     FilterType is an optional parameter for specifying how to filter data selection;

     FilterData is an optional parameter for specifying filter data.

 


© Bricsys NV. All rights reserved.