Toolbar Item object

Class AcadToolbarItem

Member of BricscadApp

A toolbar item represents a single button or separator on a toolbar. Toolbar buttons can contain a macro to be executed when they are selected by the user, or they can contain a nested toolbar called a flyout. Separators cannot contain macros or flyouts.

To add or change the macro associated with a toolbar button, use the Macro property. To create a flyout toolbar button, first set the Flyout property to acToolbarFlyout. Then use the AttachToolbarToFlyout method to attach an existing Toolbar object to the button.

You can change the bitmap associated with a button by using the SetBitmaps method. This method allows you to set both the large and small button bitmaps.

To edit or query a toolbar button, use the following methods and properties:

Methods Properties
AttachToolbarToFlyout Application
Delete Flyout
GetBitmaps HelpString
SetBitmaps Index
  Macro
  Name
  Parent
  SubMenu
  TagString
  Type

© Bricsys NV. All rights reserved.