bim:get-allrooms


(bim:get-allrooms  [building  [story]])

Returns a list of all BIM rooms, optionally for specified building and story.

Arguments

building  (optional) name of the building (string) to retrieve all rooms from

story  (optional) name of the building (string) to retrieve all rooms from

if story is not specified, then all rooms of given building are returned
if building is not specified, then all rooms of the entire drawing are returned

Return

list of room entities if any room is available, or NIL if no room is available

Example

(bim:get-allrooms)  (<ename> ... <ename>)  returns all rooms for the actual drawing
(bim:get-allrooms "Tower")  (<ename> ... <ename>)  returns all rooms for the "Tower" building
(bim:get-allrooms "Tower" "Floor-1")  (<ename> ... <ename>)  returns all rooms for the "Floor-1" story in "Tower" building

Remarks

see (bim::create-room) and (bim::create-associativeroom);
the building and story name strings are case-sensitive !



©  Bricsys NV. All rights reserved.