bim:get-isspaceupdated


(bim:get-isspacevalid  entity)

Returns whether the specified BIM "Space" entity is in updated state.

Arguments

entity  any entity (as normal entity or as VLA object name) to verify for its BIM "Space" updated status

Return

T if the entity is a valid "Space" entity and is in updated state, or NIL otherwise

Example

(if (not (bim:get-isspaceupdated ent)) (bim:update-space ent))

Remarks

see (bim:get-isspacevalid) and (bim:update-space) functions



©  Bricsys NV. All rights reserved.