file-id, integer identifier
representing a loaded dcl file, as returned by load_dialog
return value:
T on success, nil on failure
description:
This function creates a new dialog.
The name of the dialog typically appears in the dcl file as
"mydialog : dialog". The new dialog becomes the current dialog.
Subsequent calls to dcl function will affect this dialog, until
another call to new_dialog or until a call to done_dialog is made.
The newly created dialog will be disabled until a call to
start_dialog is made.