key, string identifier of a DCL tile
as it appears in the DCL file
argument 2:
optional integer operation code,
default 3
argument 3:
optional index, default 0
return value:
nil on failure, number of arguments
that were given on success (1 2 or 3)
description:
This function sets the currently
active list, its "operation code" and its index. The action code
and index alter the behaviour of future calls to add_list, until a
call to end_list is made. These are the possible operation codes:
1, CHANGE: a call to add_list will overwrite the item specified
through the index 2, APPEND: consecutive calls to add_list will
append items to the list (index is not used) 3, NEW: this is
similar to APPEND, but the list is erased first Editing a list must
be finished by calling end_list. The active list, its operation
code and its index stay valid until the next call to end_list.