Curve2dGetDistanceTo Method (Curve2d, Tolerance)

Retrieves the distance of the closest points between this curve and the passed curve within a specified tolerance.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public double GetDistanceTo(
        Curve2d curve,
        Tolerance tolerance
)

Parameters

curve
Type: Teigha.GeometryCurve2d
[in] Curve to which the distance is calculated.
tolerance
Type: Teigha.GeometryTolerance
[in] Geometric tolerance.

Return Value

Type: Double
The distance as a value of the double type.
See Also

©  Bricsys NV. All rights reserved.