IOdaBlockAddMInsertBlock Method

Namespace:  BricscadDb
Assembly:  Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
AcadMInsertBlock AddMInsertBlock(
        Object InsertionPoint,
        string Name,
        double Xscale,
        double Yscale,
        double Zscale,
        double Rotation,
        int NumRows,
        int NumColumns,
        int RowSpacing,
        int ColumnSpacing,
        [OptionalAttribute] Object Password
)

Parameters

InsertionPoint
Type: SystemObject
Name
Type: SystemString
Xscale
Type: SystemDouble
Yscale
Type: SystemDouble
Zscale
Type: SystemDouble
Rotation
Type: SystemDouble
NumRows
Type: SystemInt32
NumColumns
Type: SystemInt32
RowSpacing
Type: SystemInt32
ColumnSpacing
Type: SystemInt32
Password (Optional)
Type: SystemObject

Return Value

Type: AcadMInsertBlock

Implements

IAcadBlockAddMInsertBlock(Object, String, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Object)
See Also

©  Bricsys NV. All rights reserved.