SecurityParameters Constructor (String, String, String, String,
String, String, String, SecurityActions, SecurityAlgorithm, UInt32,
UInt32)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public SecurityParameters(
string password,
string providerName,
string subject,
string issuer,
string serialNumber,
string comment,
string timeServer,
SecurityActions actions,
SecurityAlgorithm algorithm,
uint keyLength,
uint providerType
)
Public Sub New (
password As String,
providerName As String,
subject As String,
issuer As String,
serialNumber As String,
comment As String,
timeServer As String,
actions As SecurityActions,
algorithm As SecurityAlgorithm,
keyLength As UInteger,
providerType As UInteger
)
public:
SecurityParameters(
String^ password,
String^ providerName,
String^ subject,
String^ issuer,
String^ serialNumber,
String^ comment,
String^ timeServer,
SecurityActions actions,
SecurityAlgorithm algorithm,
unsigned int keyLength,
unsigned int providerType
)
new :
password : string *
providerName : string *
subject : string *
issuer : string *
serialNumber : string *
comment : string *
timeServer : string *
actions : SecurityActions *
algorithm : SecurityAlgorithm *
keyLength : uint32 *
providerType : uint32 -> SecurityParameters
Parameters
- password
- Type: SystemString
- providerName
- Type: SystemString
- subject
- Type: SystemString
- issuer
- Type: SystemString
- serialNumber
- Type: SystemString
- comment
- Type: SystemString
- timeServer
- Type: SystemString
- actions
- Type: Teigha.DatabaseServicesSecurityActions
- algorithm
- Type: Teigha.DatabaseServicesSecurityAlgorithm
- keyLength
- Type: SystemUInt32
- providerType
- Type: SystemUInt32
See Also