DatabaseOverlayXref Method

Overlays the specified external reference file to the database. As a result a new external reference BlockTableRecord is created.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public ObjectId OverlayXref(
        string fileName,
        string blockName
)

Parameters

fileName
Type: SystemString
[in] External reference file path name.
blockName
Type: SystemString
[in] External reference block name symbol to use.

Return Value

Type: ObjectId
Identifier of a newly created BlockTableRecord.
Remarks
The document is not locked during the external reference overlay operation, and a new instance of the BlockReference instance class is not created.
See Also

©  Bricsys NV. All rights reserved.