BoundBlock2d Constructor (Point2d, Vector2d, Vector2d)
|
Constructor for the BoundBlock2d class.
Constructs a bounding block with specified base point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public BoundBlock2d(
Point2d basePoint,
Vector2d direction1,
Vector2d direction2
)
Public Sub New (
basePoint As Point2d,
direction1 As Vector2d,
direction2 As Vector2d
)
public:
BoundBlock2d(
Point2d basePoint,
Vector2d direction1,
Vector2d direction2
)
new :
basePoint : Point2d *
direction1 : Vector2d *
direction2 : Vector2d -> BoundBlock2d
Parameters
- basePoint
- Type: Teigha.GeometryPoint2d
[in] Base of a parallelogram bounding block.
- direction1
- Type: Teigha.GeometryVector2d
[in] First side of a parallelogram bounding block.
- direction2
- Type: Teigha.GeometryVector2d
[in] Second side of a parallelogram bounding block.
See Also