SymbolUtilityServicesGetMaxSymbolNameLength Method
|
Retrieves the maximum allowed length for
symbol names.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static int GetMaxSymbolNameLength(
bool isNewName,
bool compatibilityMode
)
Public Shared Function GetMaxSymbolNameLength (
isNewName As Boolean,
compatibilityMode As Boolean
) As Integer
public:
static int GetMaxSymbolNameLength(
bool isNewName,
bool compatibilityMode
)
static member GetMaxSymbolNameLength :
isNewName : bool *
compatibilityMode : bool -> int
Parameters
- isNewName
- Type: SystemBoolean
[in] Flag that specifies whether the length for extended or legacy
symbol names should be retrieved.
- compatibilityMode
- Type: SystemBoolean
[in] Flag that specifies whether extended or legacy symbol names
should be processed.
Return Value
Type:
Int32
Maximum allowed length for symbol names.
Remarks
The returned
values vary depending on the compatibilityMode flag. If set to true, the method returns 255, or 31 is returned
otherwise.
See Also