SymbolUtilityServicesValidateCompatibleSymbolName Method
|
Validates a symbol name and checks whether its
length is acceptable.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static ErrorStatus ValidateCompatibleSymbolName(
string name,
bool isNewName,
bool allowVerticalBar,
bool compatibilityMode
)
Public Shared Function ValidateCompatibleSymbolName (
name As String,
isNewName As Boolean,
allowVerticalBar As Boolean,
compatibilityMode As Boolean
) As ErrorStatus
public:
static ErrorStatus ValidateCompatibleSymbolName(
String^ name,
bool isNewName,
bool allowVerticalBar,
bool compatibilityMode
)
static member ValidateCompatibleSymbolName :
name : string *
isNewName : bool *
allowVerticalBar : bool *
compatibilityMode : bool -> ErrorStatus
Parameters
- name
- Type: SystemString
[in] Name to validate.
- isNewName
- Type: SystemBoolean
[in] Flag that specifies whether the name should be regarded as a
new name or an existing name.
- allowVerticalBar
- Type: SystemBoolean
[in] Flag that specifies whether vertical bars ("|") are allowed in
the symbol name.
- compatibilityMode
- Type: SystemBoolean
[in] Flag that specifies whether the name should be validated as an
extended or legacy symbol name.
Return Value
Type:
ErrorStatus
ErrorStatus::OK if validated
successfully, or an appropriate error code otherwise.
See Also