Spline Constructor (Int32, Boolean, Boolean, Boolean,
Point3dCollection, DoubleCollection, DoubleCollection, Double,
Double)
|
Initializes a new instance of the
Spline class
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Spline(
int degree,
bool rational,
bool closed,
bool periodic,
Point3dCollection controlPoints,
DoubleCollection knots,
DoubleCollection weights,
double controlPointTolerance,
double knotTolerance
)
Public Sub New (
degree As Integer,
rational As Boolean,
closed As Boolean,
periodic As Boolean,
controlPoints As Point3dCollection,
knots As DoubleCollection,
weights As DoubleCollection,
controlPointTolerance As Double,
knotTolerance As Double
)
public:
Spline(
int degree,
bool rational,
bool closed,
bool periodic,
Point3dCollection^ controlPoints,
DoubleCollection^ knots,
DoubleCollection^ weights,
double controlPointTolerance,
double knotTolerance
)
new :
degree : int *
rational : bool *
closed : bool *
periodic : bool *
controlPoints : Point3dCollection *
knots : DoubleCollection *
weights : DoubleCollection *
controlPointTolerance : float *
knotTolerance : float -> Spline
Parameters
- degree
- Type: SystemInt32
- rational
- Type: SystemBoolean
- closed
- Type: SystemBoolean
- periodic
- Type: SystemBoolean
- controlPoints
- Type: Teigha.GeometryPoint3dCollection
- knots
- Type: Teigha.GeometryDoubleCollection
- weights
- Type: Teigha.GeometryDoubleCollection
- controlPointTolerance
- Type: SystemDouble
- knotTolerance
- Type: SystemDouble
See Also