Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
int iUDegree,
int iVDegree,
bool bRational,
int iUNumControlPoints,
int iVNumControlPoints,
Point3dCollection ctrlPts,
DoubleCollection weights,
KnotCollection knotsInU,
KnotCollection knotsInV
)
Public Sub Set (
iUDegree As Integer,
iVDegree As Integer,
bRational As Boolean,
iUNumControlPoints As Integer,
iVNumControlPoints As Integer,
ctrlPts As Point3dCollection,
weights As DoubleCollection,
knotsInU As KnotCollection,
knotsInV As KnotCollection
)
public:
void Set(
int iUDegree,
int iVDegree,
bool bRational,
int iUNumControlPoints,
int iVNumControlPoints,
Point3dCollection^ ctrlPts,
DoubleCollection^ weights,
KnotCollection^ knotsInU,
KnotCollection^ knotsInV
)
member Set :
iUDegree : int *
iVDegree : int *
bRational : bool *
iUNumControlPoints : int *
iVNumControlPoints : int *
ctrlPts : Point3dCollection *
weights : DoubleCollection *
knotsInU : KnotCollection *
knotsInV : KnotCollection -> unit
Parameters
- iUDegree
- Type: SystemInt32
- iVDegree
- Type: SystemInt32
- bRational
- Type: SystemBoolean
- iUNumControlPoints
- Type: SystemInt32
- iVNumControlPoints
- Type: SystemInt32
- ctrlPts
- Type: Teigha.GeometryPoint3dCollection
- weights
- Type: Teigha.GeometryDoubleCollection
- knotsInU
- Type: Teigha.GeometryKnotCollection
- knotsInV
- Type: Teigha.GeometryKnotCollection
See Also