Curve2dGetArea Method (Double, Double, Tolerance)
|
Retrieves the area of the parametric interval
defined by the passed start and end parameters within the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetArea(
double startParameter,
double endParameter,
Tolerance tolerance
)
Public Function GetArea (
startParameter As Double,
endParameter As Double,
tolerance As Tolerance
) As Double
public:
double GetArea(
double startParameter,
double endParameter,
Tolerance tolerance
)
member GetArea :
startParameter : float *
endParameter : float *
tolerance : Tolerance -> float
Parameters
- startParameter
- Type: SystemDouble
[in] Start of the parameter interval.
- endParameter
- Type: SystemDouble
[in] End of the parameter interval (must be greater than
startParameter).
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Double
Area calculated between specified parameters.
See Also