CircularArc3dIntersectWith Method (CircularArc3d, Tolerance)
|
Retrieves intersection points between this
circular arc and the passed circular arc.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Point3d[] IntersectWith(
CircularArc3d arc,
Tolerance tolerance
)
Public Function IntersectWith (
arc As CircularArc3d,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ IntersectWith(
CircularArc3d^ arc,
Tolerance tolerance
)
member IntersectWith :
arc : CircularArc3d *
tolerance : Tolerance -> Point3d[]
Parameters
- arc
- Type: Teigha.GeometryCircularArc3d
[in] A 3D arc to intersect with.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Point3d
Array of intersection points.
See Also