DatabaseSaveAs Method (String, Boolean, DwgVersion,
SecurityParameters)
|
Saves content of the currently active database
according to the passed arguments.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void SaveAs(
string fileName,
bool bBakAndRename,
DwgVersion version,
SecurityParameters security
)
Public Sub SaveAs (
fileName As String,
bBakAndRename As Boolean,
version As DwgVersion,
security As SecurityParameters
)
public:
void SaveAs(
String^ fileName,
bool bBakAndRename,
DwgVersion version,
SecurityParameters^ security
)
member SaveAs :
fileName : string *
bBakAndRename : bool *
version : DwgVersion *
security : SecurityParameters -> unit
Parameters
- fileName
- Type: SystemString
[in] File name to write the database to. File extension is not
appended automatically.
- bBakAndRename
- Type: SystemBoolean
[in] Flag that specifies whether to create a .bak file and change
the document name. If not specified, no .bak file is created and
the file is not renamed.
- version
- Type: Teigha.DatabaseServicesDwgVersion
[in] A file version to which to save the file.
- security
- Type: Teigha.DatabaseServicesSecurityParameters
[in] A SecurityParameters class that represents security parameters
such as password, provider name, serial number, etc.
Remarks
If security is
non-NULL, its settings ignore any previous database security
settings, otherwise previous security settings remain unchanged. If
the security parameters are not properly initialized, the method
fails. If .dwg files can no longer be saved with passwords
specified in security parameters.
See Also