TinSurfaceStaticGetIntersectionsWithLine Method
|
Namespace: Bricscad.Civil
Assembly: BrxMgd (in BrxMgd.dll) Version:
21.0.0.15598
Syntax
public Point3dCollection GetIntersectionsWithLine(
Point3d ptLineStart,
Point3d ptLineEnd,
TinSurfaceIntersectType type,
bool includeInvisible
)
Public Function GetIntersectionsWithLine (
ptLineStart As Point3d,
ptLineEnd As Point3d,
type As TinSurfaceIntersectType,
includeInvisible As Boolean
) As Point3dCollection
public:
Point3dCollection^ GetIntersectionsWithLine(
Point3d ptLineStart,
Point3d ptLineEnd,
TinSurfaceIntersectType type,
bool includeInvisible
)
member GetIntersectionsWithLine :
ptLineStart : Point3d *
ptLineEnd : Point3d *
type : TinSurfaceIntersectType *
includeInvisible : bool -> Point3dCollection
Parameters
- ptLineStart
- Type: Teigha.GeometryPoint3d
- ptLineEnd
- Type: Teigha.GeometryPoint3d
- type
- Type: Bricscad.CivilTinSurfaceIntersectType
- includeInvisible
- Type: SystemBoolean
Return Value
Type:
Point3dCollection
See Also