Point2dRotateBy Method

Rotates this point about the specified point by the specified angle.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Point2d RotateBy(
        double angle,
        Point2d origin
)

Parameters

angle
Type: SystemDouble
[in] Rotation angle in radians.
origin
Type: Teigha.GeometryPoint2d
[in] Point relative to which rotation is computed.

Return Value

Type: Point2d
2D point that is the result of the rotation operation.
See Also

©  Bricsys NV. All rights reserved.