CircularArc3d Constructor (Point3d, Point3d, Point3d)
|
Constructor for the CircularArc3d class.
Creates a circle with the specified center and radius.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CircularArc3d(
Point3d startPoint,
Point3d point,
Point3d endPoint
)
Public Sub New (
startPoint As Point3d,
point As Point3d,
endPoint As Point3d
)
public:
CircularArc3d(
Point3d startPoint,
Point3d point,
Point3d endPoint
)
new :
startPoint : Point3d *
point : Point3d *
endPoint : Point3d -> CircularArc3d
Parameters
- startPoint
- Type: Teigha.GeometryPoint3d
[in] Start point of an arc.
- point
- Type: Teigha.GeometryPoint3d
[in] Second point of a 3-point arc.
- endPoint
- Type: Teigha.GeometryPoint3d
[in] End point of an arc.
See Also